Was muss ich bei einer Umstellung auf PHP 7 beachten?

Folgen

Falls Sie im cPanel die PHP-Version auf 7 setzen, müssen Sie einige Dinge beachten. In diesem Artikel listen wir bekannte Probleme, die mit der Umstellung auftauchen können.

1. MySQLi-Modul wurde umbenannt

Das Modul "mysqli" steht nicht mehr zur Verfügung. Es wurde durch "nd_mysqli" abgelöst. Dieses muss, wenn benötigt, im PHP-Selector manuell aktiviert werden.

Das Modul "mysqli" sollte nicht verwendet werden, da es dabei bei MySQL-Updates u.U. zu Problemen kommen kann. Diese resultieren u.A. in folgenden Fehlermeldungen:

Headers and client library minor version mismatch. Headers:100020 Library:100111

Unteranderem wird dieses Modul bei auf Joomla basierenden Webseiten benötigt.

2. PHP-Funktionen nicht mehr verfügbar

Einige CMS Systeme sind noch nicht oder nur in der neusten Version zu PHP7 kompatibel. Falls Sie die Seite selber entwickeln, finden Sie im Manual mehr Informationen zur Migration auf PHP7.

 

Haben Sie Fragen? Anfrage einreichen

Kommentare

Powered by Zendesk